PHP >=5.3.0 version required.